Как добавить нули перед числом в Excel

Иногда перед пользователем стоит задача добавить нули перед числом в Excel. Например, табельные номера, как правило, начинаются с нулей. И если вводить с клавиатуры число, начинающееся с нуля, эксель по умолчанию убирает ноль перед числом.

 

Способ 1. Текстовый формат ячеек

 

Например, нам нужно внести в таблицу excel табельные номера, начинающиеся с нулей. 

  1. Выделим ячейки, в которые нужно внести данные.
  2. Нажмем правую кнопку мыши и выберем Формат ячеек

 

как добавить нули перед числом в excel

 

1. На вкладке Число выберем Текстовый формат и нажмем Ок.

 

как добавить нули перед числом в excel

 

2. Теперь можно вносить в эти ячейки числа с любым количеством нулей в начале.

 

как добавить нули перед числом в excel

 

Однако, обратите внимание на зеленый треугольники в верхнем левом углу ячейки. В данном случае это указывает на некоторые проблемы с форматом. Дело в том, что эти числа — не совсем числа. Совершать числовые операции с ними невозможно (например, их нельзя сложить или умножить). Поэтому этот способ можно использовать только в том случае, если с этими числами не требуется делать каких-то операций.

 

Лайфхак!

 

Текстовый формат ячейке, чтобы поставить ноль перед числом в excel, можно задать более быстрым способом. 
Начинаем ввод в ячейку с одинарной кавычки, далее — нули и необходимые числа. Результат будет такой же — ячейке будет присвоен текстовый формат.

 

 

Способ 2. Как быстро добавить нули перед числами в Excel с помощью функции ТЕКСТ

 

У нас уже внесены числа без нулей, и нужно быстро добавить нули перед числами во всем столбце. Здесь поможет функция ТЕКСТ.

В столбце рядом напишем формулу:

 

=ТЕКСТ(B3;»000000″)

 

как добавить нули перед числом в excel

 

Функция ТЕКСТ преобразует значение в ячейке, на которую ссылается в указанные формат.

В примере это ячейка B3, значение в которой преобразуется в формат “000000”. Этот формат означает, что, если вы напишите в ячейке B3 число, состоящее меньше, чем из 6 цифр, то excel добавит в начале нужное количество нулей, сделав число шестизначным. 

В этой статье мы научились, как можно добавить нули перед числом в Excel.

Еще больше про форматы данных в Excel в статье:

Оставьте комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *