Как написать формулу в Excel и чем отличаются формула и функция

Пользователи Excel, даже продвинутые, зачастую путают понятия “функция” и “формула”. На самом деле, критической ошибкой это не является (ну, какая разница, как вы это назвали, если вас поняли — конечно, если вы не тренер по эксель). Однако, понимание отличия между функцией и формулой — ключ к пониманию принципов Excel. Также в этой статье разберемся, как написать формулу в Excel.

 

Чем отличаются формулы и функции в Excel

 

Функция — это встроенная в эксель (или написанная самостоятельно при помощи VBA-программирования) микро-программа, которая производит единственное вычисление.

Пример функции в Excel:

=ВПР(L2;B:C;2;0)

Формула — это вычисление в более широком смысле. Формула может:

  • содержать одну функцию

=ВПР(L2;B:C;2;0)

В данной формуле используется одна функция ВПР.

  • содержать несколько функций

=ЕСЛИ(ВПР(L2;B:C;2;0)>0;1;0)

В этой формуле используются две функции: ЕСЛИ и ВПР.

  • вообще не содержать функций

=(120 + 30) * 0,5

Данная формула не содержит ни одной функции, только числовые значения и операторы вычислений.

Таким образом, формула — это более широкое понятие, чем функция. Формула может включать одну или несколько функций. 

Формула всегда начинается со знака “=”. Любую ячейку, в которой значение начинается со знака “=”, эксель воспринимает как формулу.

 

Как написать формулу в Excel

 

Существует 2 способа написать формулу в Excel.

Способ 1. При помощи мастера функций

 

Как правило, этот способ чаще используют новички.

Нужно установить курсор в ячейку, в которой нужно написать формулу, и щелкнуть на значке Мастера функций.

как написать формулу в excel

Появится окно Вставка функции

как написать формулу в excel

В поле Поиск функции можно написать функцию, которую вы ищите, и нажать кнопку Найти или Enter.

Однако, этот поиск работает не всегда корректно. Например, введя в поле Поиск функцию “ВПР”, получаем странный результат:

как написать формулу в excel

В поле Категория можно выбрать категорию функции. Например, в категории “Текстовые” выйдут все функции для работы с текстом.

 

Способ 2. Ввод формулы в строку формул или в ячейку.

 

Строка формул находится между вкладками и рабочим пространством листа excel.

как написать формулу в excel

Ввод формулы в excel через строку формул или через ячейку ничем не отличается. Если вы начнете писать формулу в строке формул, то она будет дублироваться в активной ячейке (в которой установлен курсор), и наоборот.

Ввод формулы всегда нужно начинать со знака “=”.

Если вы используете функцию при вводе формулы вручную, то функцию можно также написать вручную или выбрать из мастера функций в процессе написания формулы.

Рассмотрим написание формул в excel на примерах.

 

Пример ввода формулы в Excel через мастер функций

 

Имеем три числа в ячейках А1,А2 и А3. Необходимо в ячейке А4 получить среднее значение этих чисел.

Подробнее о том, как получить среднее значение.

Устанавливаем курсор в ячейке А4 и нажимаем на значок мастера функций.

как написать формулу в excel

В поле Поиск функции пишем СРЗНАЧ и нажимаем кнопку Найти.

как написать формулу в excel

В полученном списке находим искомую функцию (как правило, она самая первая), выделяем ее и нажимаем Ок.

Появляется окно, в котором нужно указать аргументы функции. Аргументы функции в excel бывают обязательными (без указания которых функция выдаст ошибку) и необязательными. Обязательные аргументы выделены жирным шрифтом.

как написать формулу в excel

Устанавливаем курсор в поле Число 1 и левой кнопкой мыши выделяем сразу три наших числа. В поле появляется ссылка на массив (см. предыдущую картинку). Если вдруг выделили неправильно, сотрите и повторите операцию.

После этого нажимаете Ок.

В ячейке А4 получаем искомое среднее значение.

как написать формулу в excel

 

Пример ввода формулы в Excel через строку формул

 

Имеем такие же данные, как для предыдущего примера: три числа в ячейках А1:А3.

Устанавливаем курсор в ячейку А4, в которой нужно получить итоговое среднее значение. 

Далее щелкам левой кнопкой мыши в строке формул и пишем с клавиатуры:

=СРЗНАЧ( 

После того, как открыли скобку, мышкой выделяем диапазон, по которому нужно получить среднее А1:А3. Закрываем скобку и нажимаем Enter. В итоге должно получиться так:

как написать формулу в excel

Чтобы больше узнать про формулы и функции в Excel, прочитайте статьи:

Оставьте комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *