Как найти дубликаты в Excel

Поиск дубликатов в Excel — рутинная задача при работе с данными. Повторяющиеся значения могут быть проблемой при использовании различных функций, поэтому иногда их требуется только подсветить, а иногда — и удалить. В этой статье узнаем, как найти дубликаты в Excel.

Поиск дубликатов в excel можно сделать несколькими способами. В этой статье рассмотрим два самых распространенных способа подсветить дубликаты, а также прием для поиска номера вхождения элемента в список Excel.

Видео для тех, кто не любит читать

Как подсветить дубликаты в Excel при помощи условного форматирования

 

В списке с ФИО сотрудников есть повторяющиеся значения. 

Для того, чтобы найти дубликаты, в excel есть специальный инструмент условного форматирования.

Выделим список и перейдем во вкладку Главная — блок СтилиУсловное форматированиеПравила выделения ячеекПовторяющиеся значения.

как найти дубликаты в excel

В окне Повторяющиеся значения также можно выделить уникальные значения.

как найти дубликаты в excel

Есть возможность выбрать формат ячеек из заданных или настроить свой Пользовательский формат.

как найти дубликаты в excel

Дубликаты выделены цветом. Если ваша задача — просто найти и подсветить дубликаты в Excel, то этот способ идеально подходит.

как найти дубликаты в excel


   Сообщество Excel Analytics | обучение Excel

    Канал на Яндекс.Дзен 


 

Как найти количество повторяющихся значений в списке Excel

 

У предыдущего способа есть нюанс — он выделяет все дубликаты, вне зависимости от их количества. Обратите внимание на предыдущей картинке, что сотрудник Семенов Петр Геннадьевич встречается в списке 3 раза.

Если нужно определить количество повторяющихся значений в списке Excel, то есть формула для определения количества дубликатов.

В ячейке С2 напишем формулу:

 

=СЧЁТЕСЛИ($B$2:$B$16;B2)

 

Обязательно закрепим абсолютными ссылками (знак $) диапазон поиска, чтобы он не съезжал при копировании формулы. 

Скопируем формулу до конца списка.

 

как найти дубликаты в excel

Синтаксис функции СЧЁТЕСЛИ:

 

=СЧЁТЕСЛИ(диапазон;критерий).

 

Функция СЧЁТЕСЛИ ищет критерий в заданном диапазоне ячеек и выводит количество совпадений.

 

Номер вхождения элемента списка

 

В предыдущих примерах мы определили, что Семенов Петр Геннадьевич встречается в списке 3 раза, а Лобков Иван Сергеевич — 2 раза. 

Теперь найдем номер вхождения каждого элемента в список. Ну то есть, где Семенов П.Г. встретился первый раз, где второй и третий. На практике это достаточно частая задача, которая, например, используется для функции ВПР с несколькими условиями.

В первую ячейку рядом со списком напишем формулу:

=СЧЁТЕСЛИ($B$1:B2;B2)

 

Обратите внимание, что абсолютной ссылкой ($) закреплено только начало диапазона. Конец диапазона же будет меняться вместе с ячейкой формулы.

как найти дубликаты в excel

Суть этой формулы в том, что в данном случае функция СЧЁТЕСЛИ ищет совпадения критерия не со всем диапазоном, а только с тем, что находится от данной строки и выше.

 

Как удалить дубликаты в Excel

 

Чтобы удалить повторяющиеся значения, выделим диапазон и перейдем во вкладку Данные — блок Работа с даннымиУдалить дубликаты.

как найти дубликаты в excel
В окне Удалить дубликаты нажмем Ок.

как найти дубликаты в excel

Готово, теперь список не содержит повторяющихся значений.

как найти дубликаты в excel

В этой статье мы узнали, как найти и подсветить дубликаты в Excel, определить номер вхождения элемента в список. А также научились удалять повторяющиеся значения.

Оставьте комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *